انجمن‌های فارسی اوبونتو

لطفاً به انجمن‌ها وارد شده و یا جهت ورود ثبت‌نام نمائید

لطفاً جهت ورود نام کاربری و رمز عبورتان را وارد نمائید

اوبونتو ۲۴٫۰۴ با پشتیبانی بلند مدّت (۱۲ سال) منتشر شد 🎉

نویسنده موضوع: عدم کارکرد شتاب سخت‌افزاری (VAAPI) در اوبونتو  (دفعات بازدید: 1384 بار)

0 کاربر و 1 مهمان درحال مشاهده موضوع.

آفلاین میمو ☕

  • High Hero Member
  • *
  • ارسال: 1034
  • جنسیت : پسر
  • mrostd سابق
وقت به‌خیر.
یکی از اولین کارهایی که من بعد از نصب توزیع انجام می‌دم فعال‌سازی شتاب سخت‌افزاری برای پخش ویدئو است.
من یه پردازندهٔ i5-10400 دارم که گرافیک آنبورد uhd 630 روی اونه، این گرافیک در بستهٔ intel-media-driver که برای سی‌پی‌یوهای بعد از نسل ۸ است وجود داره و اغلب هم توی تمام توزیع‌ها بدون مشکل کار می‌کنه.
اما درمورد اوبونتو (حداقل نسخهٔ ۲۳.۰۴) اینطور نیست..
طبق راهنمای زیر، من بستهٔ intel-media-va-driver (و بعد از ناکامی، intel-media-va-driver-non-free) رو نصب کردم، اما در کمال تعجب از شتاب‌سنج سخت‌افزاری برای دی‌کد شدن ویدئوها در پلیرها استفاده نمی‌شه.
https://wiki.debian.org/HardwareVideoAcceleration#VA-API
من از VLC و Clapper که جفتشون به خوبی با vaapi هماهنگ هستند استفاده می‌کنم، نکته‌ای که درمورد vlc وجود داره اینه که اصلا vaapi رو تو لیست hardware accelerated decoding نداره، پلیر Clapper هم که به‌صورت پیش‌فرض از شتاب سخت‌افزاری پشتیبانی می‌کنه بعد از مدتی دیگه نمی‌تونه به درستی ویدئو رو پخش کنه و روی یه فریم گیر می‌کنه (احتمالا چون نتونسته vaapi رو پیدا کنه).
من اسنپ رو هم امتحان کردم، VLC اینبار گزینهٔ vaapi رو داشت، اما همچنان در خروجی دستور intel_gpu_top خبری از دیکد شدن با GPU نبود و Clapper هم باز به رفتار قبلیش ادامه می‌داد..
درمورد flatpak اما همه چیز به خوبی کار می‌کنه، و شتاب سخت‌افزاری کاملا بی‌مشکله، همچنین Clapper هم روی flatpak عیب و ایرادی نداره.
بعد از جسنجو متوجه شدم اینجا هم کسی در دبیان ۱۲ مشکل مشابه من رو داشته:
https://forum.level1techs.com/t/no-hardware-acceleration-on-debian-12/198595
من مطمئنم جایی رو اشتباه نرفتم، توی فدورا، آرچ و... هرگز مشکلی نداشتم، اما اینجا فقط از طریق فلت‌پک می‌تونم از این قابلیت بهره ببرم، خوشحال می‌شم اگه کسی اطلاعی در رابطه با این موضوع داره به اشتراک بذاره.
« آخرین ویرایش: 31 شهریور 1402، 04:45 ق‌ظ توسط میمو ☕ »

آفلاین بریتانیای کبیر

  • High Hero Member
  • *
  • ارسال: 2395
  • جنسیت : پسر
  • GOD SAVE THE KING/QUEEN
من اینجا
https://forums.linuxmint.com/viewtopic.php?t=350311به بسته linux-oem-20.04b رسیدم که البته فکر کنم الانش باشه linux-oem-22.04 و چنتا a, b , c  دیگه هم داره.
🇬🇧🏴󠁧󠁢󠁥󠁮󠁧󠁿🏴󠁧󠁢󠁷󠁬󠁳󠁿🏴󠁧󠁢󠁳󠁣󠁴󠁿🇬🇧

آفلاین میمو ☕

  • High Hero Member
  • *
  • ارسال: 1034
  • جنسیت : پسر
  • mrostd سابق
من اینجا
https://forums.linuxmint.com/viewtopic.php?t=350311به بسته linux-oem-20.04b رسیدم که البته فکر کنم الانش باشه linux-oem-22.04 و چنتا a, b , c  دیگه هم داره.
کارساز نبود، درواقع گمون نکنم ارتباطی به مشکلی که من دارم هم داشته باشه، به‌نظر مشکل از بسته‌هاست و باگ یا همچین چیزی باید باشه.
موقتا با فلت‌پک مشکل حل شده.
با این حال اگه کسی شرایط مشابه من رو داره خوشحال می‌شم بگه راهکاری پیدا کرده یا نه.

آفلاین میمو ☕

  • High Hero Member
  • *
  • ارسال: 1034
  • جنسیت : پسر
  • mrostd سابق
مشکل در نسخهٔ بتای ۲۳.۱۰ هم پابرجا بود.