انجمن‌های فارسی اوبونتو

لطفاً به انجمن‌ها وارد شده و یا جهت ورود ثبت‌نام نمائید

لطفاً جهت ورود نام کاربری و رمز عبورتان را وارد نمائید

اوبونتو ۲۴٫۰۴ با پشتیبانی بلند مدّت (۱۲ سال) منتشر شد 🎉

نویسنده موضوع: matrix synapse + Element/web  (دفعات بازدید: 2846 بار)

0 کاربر و 1 مهمان درحال مشاهده موضوع.

آفلاین Matin Taghavi

  • Full Member
  • *
  • ارسال: 130
  • جنسیت : پسر
  • MAth!N
matrix synapse + Element/web
« : 06 دی 1402، 12:26 ق‌ظ »
به تازگی روی سرور matrix راه اندازی کردن به همراه Element/web که شاید به riot بشناسید.
همه چیز درست پیش‌میره اما موقع ساخت اکانت جدید روی ماتریکس با پیغام بسته بودن ریجستری هوم سرور مواجه میشم.
محتوای فایل homeserver.yaml هم با محتوای گفته شده فرق میکنه و خط فعال سازی ریجستری رو نداره!
کسی هیت تجربه ای داشته باشه بتونه بگه ریجستری رو از کجا فعال کنم؟؟
GNU/Linux user [Debian trixie, GNOME 44.3]

آفلاین دانیال بهزادی

  • ناظر انجمن
  • *
  • ارسال: 19598
  • جنسیت : پسر
  • Urahara Kiesuke
    • وبلاگ
پاسخ : matrix synapse + Element/web
« پاسخ #1 : 06 دی 1402، 06:37 ق‌ظ »
چه نگارشی از سینپس رو داری؟
اگه این ارسال بهت کمک کرد، دنبال دکمهٔ تشکر نگرد. به جاش تو هم به جامعهٔ آزادت کمک کن

آفلاین Matin Taghavi

  • Full Member
  • *
  • ارسال: 130
  • جنسیت : پسر
  • MAth!N
پاسخ : matrix synapse + Element/web
« پاسخ #2 : 06 دی 1402، 09:46 ق‌ظ »
« آخرین ویرایش: 06 دی 1402، 10:08 ق‌ظ توسط Matin Taghavi »
GNU/Linux user [Debian trixie, GNOME 44.3]

آفلاین دانیال بهزادی

  • ناظر انجمن
  • *
  • ارسال: 19598
  • جنسیت : پسر
  • Urahara Kiesuke
    • وبلاگ
پاسخ : matrix synapse + Element/web
« پاسخ #3 : 06 دی 1402، 11:28 ق‌ظ »
توی پیکربندی سینپس این خط رو بیفزا:
enable_registration: true
اگه این ارسال بهت کمک کرد، دنبال دکمهٔ تشکر نگرد. به جاش تو هم به جامعهٔ آزادت کمک کن

آفلاین Matin Taghavi

  • Full Member
  • *
  • ارسال: 130
  • جنسیت : پسر
  • MAth!N
پاسخ : matrix synapse + Element/web
« پاسخ #4 : 06 دی 1402، 11:29 ق‌ظ »
توی پیکربندی سینپس این خط رو بیفزا:
enable_registration: true

موقع ری‌استارت خطا میده
systemctl restart matrix-synapse.service
Job for matrix-synapse.service failed because the control process exited with error code.
See "systemctl status matrix-synapse.service" and "journalctl -xeu matrix-synapse.service" for details.

محتویات فایل هوم سرور:# Configuration file for Synapse.
#
# This is a YAML file: see [1] for a quick introduction. Note in particular
# that *indentation is important*: all the elements of a list or dictionary
# should have the same indentation.
#
# [1] https://docs.ansible.com/ansible/latest/reference_appendices/YAMLSyntax.html
#
# For more information on how to configure Synapse, including a complete accounting of
# each option, go to docs/usage/configuration/config_documentation.md or
# https://matrix-org.github.io/synapse/latest/usage/configuration/config_documentation.html
#
# This is set in /etc/matrix-synapse/conf.d/server_name.yaml for Debian installations.
# server_name: "SERVERNAME"
pid_file: "/var/run/matrix-synapse.pid"
listeners:
  - port: 8008
    tls: false
    type: http
    x_forwarded: true
    bind_addresses: ['::1', '127.0.0.1']
    resources:
      - names: [client, federation]
        compress: false
database:
  name: sqlite3
  args:
    database: /var/lib/matrix-synapse/homeserver.db
log_config: "/etc/matrix-synapse/log.yaml"
media_store_path: /var/lib/matrix-synapse/media
signing_key_path: "/etc/matrix-synapse/homeserver.signing.key"
trusted_key_servers:
  - server_name: "matrix.org"
« آخرین ویرایش: 06 دی 1402، 11:35 ق‌ظ توسط Matin Taghavi »
GNU/Linux user [Debian trixie, GNOME 44.3]

آفلاین Matin Taghavi

  • Full Member
  • *
  • ارسال: 130
  • جنسیت : پسر
  • MAth!N
پاسخ : matrix synapse + Element/web
« پاسخ #5 : 06 دی 1402، 11:42 ق‌ظ »
 
خروجی journalctl -xeu matrix-synapse.service


░░ The unit matrix-synapse.service completed and consumed the indicated resources.
Dec 27 08:09:05 mathin systemd[1]: Starting matrix-synapse.service - Synapse Matrix homeserver...
░░ Subject: A start job for unit matrix-synapse.service has begun execution
░░ Defined-By: systemd
░░ Support: https://www.debian.org/support
░░
░░ A start job for unit matrix-synapse.service has begun execution.
░░
░░ The job identifier is 7612.
Dec 27 08:09:08 mathin matrix-synapse[24912]: This server is configured to use 'matrix.org' as its tru>Dec 27 08:09:08 mathin matrix-synapse[24912]: 'trusted_key_servers' config option. 'matrix.org' is a g>Dec 27 08:09:08 mathin matrix-synapse[24912]: server since it is long-lived, stable and trusted. Howev>Dec 27 08:09:08 mathin matrix-synapse[24912]: wish to use another server for this purpose.
Dec 27 08:09:08 mathin matrix-synapse[24912]: To suppress this warning and continue using 'matrix.org'>Dec 27 08:09:08 mathin matrix-synapse[24912]: 'suppress_key_server_warning' to 'true' in homeserver.ya>Dec 27 08:09:08 mathin matrix-synapse[24912]: -------------------------------------------------------->Dec 27 08:09:08 mathin matrix-synapse[24912]: Config is missing macaroon_secret_key
Dec 27 08:09:08 mathin systemd[1]: Started matrix-synapse.service - Synapse Matrix homeserver.
« آخرین ویرایش: 06 دی 1402، 11:44 ق‌ظ توسط Matin Taghavi »
GNU/Linux user [Debian trixie, GNOME 44.3]

آفلاین Matin Taghavi

  • Full Member
  • *
  • ارسال: 130
  • جنسیت : پسر
  • MAth!N
پاسخ : matrix synapse + Element/web
« پاسخ #6 : 06 دی 1402، 08:51 ب‌ظ »
توی پیکربندی سینپس این خط رو بیفزا:
enable_registration: true

الان با کلی کار بلاخره اضافه شد و ارور نمیده موقع ری‌استارت.
اما دیگه حتی با خط فرمان هم به طور دستی نمیشه یوزر ساخت و این خطا زو میده No 'registration_shared_secret' or 'registration_shared_secret_path' defined in config.


و این هم محتویات کلی homeserver.yaml
# Configuration file for Synapse.
#
# This is a YAML file: see [1] for a quick introduction. Note in particular
# that *indentation is important*: all the elements of a list or dictionary
# should have the same indentation.
#
# [1] https://docs.ansible.com/ansible/latest/reference_appendices/YAMLSyntax.html
#
# For more information on how to configure Synapse, including a complete accounting of
# each option, go to docs/usage/configuration/config_documentation.md or
# https://matrix-org.github.io/synapse/latest/usage/configuration/config_documentation.html
#
# This is set in /etc/matrix-synapse/conf.d/server_name.yaml for Debian installations.
# server_name: "SERVERNAME"
pid_file: "/var/run/matrix-synapse.pid"
listeners:
  - port: 8008
    tls: false
    type: http
    x_forwarded: true
    bind_addresses: ['::1', '127.0.0.1']
    domain: ***
    registration_shared_secret: ***
    enable_registration: true
#    enable_registration_captcha: true
#    suppress_key_server_warning: true
#    enable_registration_without_verification: true
    resources:
      - names: [client, federation]
        compress: false
database:
  name: sqlite3
  args:
    database: /var/lib/matrix-synapse/homeserver.db
log_config: "/etc/matrix-synapse/log.yaml"
media_store_path: /var/lib/matrix-synapse/media
signing_key_path: "/etc/matrix-synapse/homeserver.signing.key"
trusted_key_servers:
  - server_name: "matrix.org"
GNU/Linux user [Debian trixie, GNOME 44.3]

آفلاین Matin Taghavi

  • Full Member
  • *
  • ارسال: 130
  • جنسیت : پسر
  • MAth!N
پاسخ : matrix synapse + Element/web
« پاسخ #7 : 07 دی 1402، 09:28 ب‌ظ »
خب بعد کلی تلاش راهنماهای مختلف الان فقط میشه با خط فرمان کاربر اضافه کرد و هنوز هم خطای Registration has been disabled on this homeserver میده!
حتی با اضافه کردن     enable_registration: true
    enable_registration_captcha: true
    suppress_key_server_warning: true
    enable_registration_without_verification: true
به listeners هم مشکل حل نمیشه!



محتوای homeserver.yaml
pid_file: "/var/run/matrix-synapse.pid"
listeners:
  - port: 8008
    tls: false
    type: http
    x_forwarded: true
    bind_addresses: ['::1', '127.0.0.1']
    resources:
      - names: [client, federation]
        compress: false
database:
  name: sqlite3
  args:
    database: /var/lib/matrix-synapse/homeserver.db
log_config: "/etc/matrix-synapse/log.yaml"
media_store_path: /var/lib/matrix-synapse/media
signing_key_path: "/etc/matrix-synapse/homeserver.signing.key"
trusted_key_servers:
  - server_name: "matrix.org"
registration_shared_secret: "***secret***"
GNU/Linux user [Debian trixie, GNOME 44.3]