انجمن‌های فارسی اوبونتو

لطفاً به انجمن‌ها وارد شده و یا جهت ورود ثبت‌نام نمائید

لطفاً جهت ورود نام کاربری و رمز عبورتان را وارد نمائید

اوبونتو ۲۴٫۰۴ با پشتیبانی بلند مدّت (۱۲ سال) منتشر شد 🎉

نویسنده موضوع: مشکل پخش صدا از اسپیکر  (دفعات بازدید: 218 بار)

0 کاربر و 1 مهمان درحال مشاهده موضوع.

آفلاین amirsefidgar82

  • Newbie
  • *
  • ارسال: 2
  • جنسیت : پسر
مشکل پخش صدا از اسپیکر
« : 29 خرداد 1403، 11:56 ق‌ظ »
سلام دوستان بنده بعد از نصب اوبونتو به این مشکل خوردم که صدا از اسپیکر لپتاپم پخش نمیشه ولی از هندزفری یا هدفون پخش میشه نسخه ای که نصب کردم ۲۲ هستش

مطالب زیادی رو راجع به این مشکل خوندم ولی هیچکدوم کمکی بهم نکرد ممنون میشم کمکم کنید

آفلاین بریتانیای کبیر

  • High Hero Member
  • *
  • ارسال: 2424
  • جنسیت : پسر
  • GOD SAVE THE KING/QUEEN
پاسخ : مشکل پخش صدا از اسپیکر
« پاسخ #1 : 29 خرداد 1403، 12:07 ب‌ظ »
درود دوست عزیز. نگارش اوبونتوی شما قدیمیه. باید اونو به نگارش بعدی ارتقا بدید. این کار سادست با یک دستور فقط.
شما میتونید چنتا کار بکنید

۱- اگه کارت گرافیکتون اینتل یا amd هست ، مستقیم برید دبیانو نصب کنید و بعد در دبیان این مشکل اگه بود رفعش میکنیم. اگه در نصب دبیان مشکل یا پرسشی داشتید بگید.

۲- اگه تازه کارید و فعلا حوصله‌ی ندارید و برای گنو لینوکس هم دو دلید روی همین اوبونتو بمونیم و این مشکلو رفع کنیم و بعد ارتقاش بدیم.

خب حالا کدوم؟

برای دومی کارای زیر را بکنید.

بسته‌ی inxi را نصب کنید.
sudo apt install inxi
بعد خروجی دستورات زیر را در تگ کد که علامتش دکمه‌ی # هست را بفرستید.
inxi -A
مدل و سازنده‌ی دستگاهتونو بگید.
inxi -b
« آخرین ویرایش: 29 خرداد 1403، 12:14 ب‌ظ توسط بریتانیای کبیر »
🇬🇧🏴󠁧󠁢󠁥󠁮󠁧󠁿🏴󠁧󠁢󠁷󠁬󠁳󠁿🏴󠁧󠁢󠁳󠁣󠁴󠁿🇬🇧

آفلاین amirsefidgar82

  • Newbie
  • *
  • ارسال: 2
  • جنسیت : پسر
پاسخ : مشکل پخش صدا از اسپیکر
« پاسخ #2 : 29 خرداد 1403، 12:38 ب‌ظ »
Audio:
  Device-1: AMD Renoir Radeon High Definition Audio driver: snd_hda_intel
  Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor
    driver: snd_rn_pci_acp3x
  Device-3: AMD Family 17h HD Audio driver: snd_hda_intel
  Sound Server-1: ALSA v: k6.5.0-35-generic running: yes
  Sound Server-2: PulseAudio v: 15.99.1 running: yes
  Sound Server-3: PipeWire v: 0.3.48 running: yes


System:
  Host: Amirhossein-PC Kernel: 6.5.0-35-generic x86_64 bits: 64
    Desktop: GNOME 42.9 Distro: Ubuntu 22.04.4 LTS (Jammy Jellyfish)
Machine:
  Type: Convertible System: HP product: HP ENVY x360 2-in-1 Laptop 15-ey0xxx
    v: Type1ProductConfigId serial: <superuser required>
  Mobo: HP model: 8A31 v: 26.42 serial: <superuser required> UEFI: Insyde
    v: F.14 date: 07/05/2023
Battery:
  ID-1: BAT1 charge: 9.8 Wh (21.6%) condition: 45.4/51.0 Wh (88.9%)
    volts: 11.1 min: 11.6
CPU:
  Info: 6-core AMD Ryzen 5 5625U with Radeon Graphics [MT MCP] speed (MHz):
    avg: 1107 min/max: 400/4388
Graphics:
  Device-1: AMD Barcelo driver: amdgpu v: kernel
  Device-2: Quanta HP True Vision 5MP Camera type: USB driver: uvcvideo
  Display: wayland server: X.Org v: 1.22.1.1 with: Xwayland v: 22.1.1
    compositor: gnome-shell driver: gpu: amdgpu resolution: 1920x1080~60Hz
  OpenGL: renderer: RENOIR (renoir LLVM 15.0.7 DRM 3.54 6.5.0-35-generic)
    v: 4.6 Mesa 23.2.1-1ubuntu3.1~22.04.2
Network:
  Device-1: MEDIATEK driver: mt7921e
Drives:
  Local Storage: total: 953.87 GiB used: 11.69 GiB (1.2%)
Info:
  Processes: 374 Uptime: 1h 11m Memory: 7.06 GiB used: 1.61 GiB (22.9%)
  Shell: Bash inxi: 3.3.13


ممنونم از راهنماییت ترجیح میدم همین اوبونتو بمونم چون خیلی تازه کارم

آفلاین بریتانیای کبیر

  • High Hero Member
  • *
  • ارسال: 2424
  • جنسیت : پسر
  • GOD SAVE THE KING/QUEEN
پاسخ : مشکل پخش صدا از اسپیکر
« پاسخ #3 : 29 خرداد 1403، 12:54 ب‌ظ »
مثله اینکه مشکل اینکه هم PulseAudio و هم PipeWire با هم فعالن.

بزنید
  sudo systemctl disable --now pulseaudio.service  pulseaudio.socketبعد بزنید
sudo apt remove pulseaudio
بعدش رایانه رو دوباره راه‌اندازی کنید(ری استارت کنید) و نتیجه رو امتحان کنید. اگه خطایی داد بزاریدش و کلا نتیجه‌ی کارو بگید که کار کرد یا نه. فعلا نمیدونم alsa sound server چیه، کارای بالا رو بکنید بعدا اگه باز درست نشد میزنیم اونم خاموش میکنیم.

نقل‌قول
ممنونم از راهنماییت ترجیح میدم همین اوبونتو بمونم چون خیلی تازه کارم
ربطی به تازه کار بودن نداشت. دبیانم برای تازه کارا عالیه. برای این گفتم که اگه فعلا گنو لینوکسو برای امتحان و ارزیابی نصب کردید باید بدونید که اوبونتو بخاطر اسنپ خیلی سنگینه و گفتم که همین اول کار فعلا روی یه چیز بمونید. اگه اوبونتو براتون خیلی کند بود برید روی دبیان.
خب پس ولی بدونید اوبونتو چون اسنپ داره خیلی کنده و کندی و افتضاح بودن اونو به پای سیستم عامل گنو نزارید.
یک آموزش درباره‌ی گنو لینوکسو در خوصوصی تون فرستادم. حتما ببینیدش.




ویرایش: 14:31
مثله اینکه باید بسته‌ی alsa-tools را هم حذف کنید. علاوه بر کارهای ابتدای همین فرستم دستور زیر را بزنید، بعد رایانه را خاموش روشن کنید و بعد نتیجه رو امتحان کنید و نتیجه رو اینجا بگید. اگه موضوع حل شد با ویرایش فرسته‌ی اولتون توی این سوال یک (حل شد) به انتهای موضوع اون اضافه کنید.

sudo apt remove alsa-tools
« آخرین ویرایش: 29 خرداد 1403، 02:38 ب‌ظ توسط بریتانیای کبیر »
🇬🇧🏴󠁧󠁢󠁥󠁮󠁧󠁿🏴󠁧󠁢󠁷󠁬󠁳󠁿🏴󠁧󠁢󠁳󠁣󠁴󠁿🇬🇧